NewXSecurityIf you use Netgear routers in your home or office network, you should be aware of the latest security threat. The company has confirmed that three lines of its routers may have these issues:

• R6400
• R7000
• R8000 series

At this time, it has not been confirmed if or whether the R7000P, R7500, R7800, R8500 or R9000 models are also vulnerable. The flaw was discovered by CERT, which is a federally funded agency that investigates software vulnerabilities and coordinates industry responses.

There are a couple of interesting things to note about this particular vulnerability. It does require action on your part to expose the router to risk. Specifically, you’ve got to click on a corrupted link. Doing so will send root-level commands to your router, essentially taking it over and enabling the hackers to intercept any traffic running across your network.

This, of course, includes passwords, credit card numbers, banking information and the like. Once the router is under hacker control, they have access to everything.

The flaw is so severe that Netgear recommends simply unplugging the router until you can upgrade the firmware. The company has moved quickly on that front and has a beta patch available on their site. If you own any of the three models listed above, you should update immediately and continue checking Netgear’s website to ensure that none of their other models have been impacted.

This latest flaw underscores just how vulnerable digital systems are. It doesn’t matter how much you’ve spent on network security; a flaw like this can make it impossible to protect your company or personal data.

If you’re concerned about this and other issues of digital security, contact us today. One of our knowledgeable team members will be happy to work with you to help ensure your protection is as robust as it can be.

Used with permission from Article Aggregator